We do NOT recommend downloading Netscape 8.0 or higher if you use Netscape for your email.  The version 8.0 does NOT support POP3 / SMTP email.  That means you can only use Netscape 8.x for webmail (email anywhere), and you will not be able to save your emails on your computer.  If you use Netscape, we suggest you stay with your version 7.x.

However, if you do not use Netscape for email, the latest version can be found here.


Return to home page